[Ardour-Users] Cannot use real-time scheduling on Fedora23

George Vergis g_vergis at yahoo.com
Mon Feb 8 19:53:40 PST 2016

Thank you Tim


Sent from my iPad

> On Feb 8, 2016, at 3:22 PM, Tim <lists at kiuni.de> wrote:
> Ahhh, forgot about putting yourself to jackuser group:
> usermod -a -G jackuser username
> Am 8. Februar 2016 18:15:30 MEZ, schrieb George Vergis <g_vergis at yahoo.com>:
>> Hi Tim
>> I am glad you got realtime scheduling with kernel-rt. I am looking forward to your documentation. I also appreciate your willingness to help. Please see my inline reply below
>> Thanks
>> George
>>> On Feb 8, 2016, at 4:36 AM, Tim <lists at kiuni.de> wrote:
>>> Yes, I'm doing a documentation to install a Fedora Audio Production machine, but I'm not finished in writing all down.
>>> Do you run realTimeConfigQuickScan? It's interesting that the ccrma kernel is not recognized as a realtime kernel by this script. But this kernels config parameters seem to be fine
>>> >>My first time hearing about it
>>> Some more questions:
>>> 1. Did you write a udev rule for rtc0 and hpet?
>> >>No, but will look for documentation on it on the web.
>>> 2. Have you tried commenting out the lines for pulse-rt and setting memory limit to unlimited?
>> >>No. Wouldn't this setting equally affect the normal Kernel. (Standard kernel can schedule realtime). Regardless, I will try the settings and report back. (Don't have access to the computer at the moment)
>>> 3. What about max_user_watches and swappiness in your /etc/sysctl.conf?
>> >>I kept the default Fedora installation settings. 
>>> 4. Did you use the server image for installation? When using the server iso you can switch to a mirror near you as installation source and you will a lot of installation options, i.e. another desktop environment.
>> >>I used the official Workstation ISO. But very good idea on using a leaner desktop manager
>>> Regards
>>> Tim
>>> Am 31. Januar 2016 04:02:27 MEZ, schrieb George Vergis <g_vergis at yahoo.com>:
>>>> Hi All,
>>>> I am not able to run jack in realtime mode with planet CCRMA kernel (4.1.12-300.rt13.1.fc23.ccrma.x86_64+rt). However, I can boot to a standard kernel and run jack with realtime scheduling privileges (Kernel: 4.3.3-303.fc23.x86_64). So I am assuming the permission and limits configuration common to both Kernel is not the issue.
>>>> The error I get is...
>>>> Cannot use real-time scheduling (RR/60)(1: Operation not permitted)
>>>> AcquireSelfRealTime error
>>>> These are steps I have taken so far...and still get the error above.
>>>> 1) Adding the username to jackuser and audio group  
>>>>     groups>> wheel audio users jackuser pulse-rt
>>>> 2) Adjusted /etc/security/limits.d/95-jack.conf
>>>>     @jackuser - rtprio 95
>>>>     @jackuser - memlock 4194304
>>>>     @pulse-rt - rtprio 20
>>>>     @pulse-rt - nice -20
>>>> 3) Rebooted the kernel.
>>>> Just curious: is there anyone running the latest fedora, fedora 23, and the kernel-rt for audio production? 
>>>> Any help is appreciated
>>>> Thanks
>>>> George
>>>> Ardour-Users mailing list
>>>> ardour-users at lists.ardour.org
>>>> To unsubscribe  or change your mailing preferences please visit:
>>>> http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20160208/8d31da2c/attachment-0002.htm>

More information about the Ardour-Users mailing list