[Ardour-Users] an A4 session that doesn't start anymore

Robin Gareus robin at gareus.org
Wed Nov 18 04:12:47 PST 2015

[message re-arranged to avoid top-posting]

On 11/18/2015 12:37 PM, Gunter Königsmann wrote:
> On 18.11.2015 06:22, fred wrote:
>> Le 17/11/2015 23:41, Robin Gareus a écrit :
>>> On 11/17/2015 09:54 PM, fred wrote:
>>>> Hi list,
>>>> mix was almost done, just like to work on common reverb (IR lv2 on a
>>>> stereo bus).
>>>> transport was rolling, I double clic on the IR plugin up-left in the
>>>> editor view.
>>>> A4 (from the site) immediatly freeze.
>>> IR.lv2 is know for causing issues on session reload and GUI access,
>>> mainly due to https://github.com/FFTW/fftw3/issues/16  which results
>>> memory corruption and undefined behavior.
>>> Recent Ardour nightly builds come with a thread-safe version of the fftw
>>> library (upcoming fftw-3.3.5 from git) which should solve this issue:
>>> http://nightly.ardour.org/
>> does it mean that Ardour from Git will include it in a few days?
> As far as I understand it this time the problem cannot be solved on 
> ardour's side: It is caused by a bug in fftw. But installing a fftw
> from git that no more contains the bug and then building ardour with
> this fftw solves the problem.


>> in session file, have tried to remove the <processor> lines with IR
>> (3 instances) but it doesn't solved the problem. did I have too to
>> remove the IR plugin directory in the plugins directory?

You can run   Ardour4 --disable-plugins   (it won't loose plugin state).

Recent Ardour 4.4-git also has a "Safe mode: disable plugins" checkbox
in the Open Session dialog.

It could also be that we're on the wrong track and this is a different
issue, after all.

Paul asked you to post a few lines from before the backtrace, that may
shed some light.


More information about the Ardour-Users mailing list