[Ardour-Users] trouble with retaining microphone connectivity over multiple sessions in Ardou

Paul Davis paul at linuxaudiosystems.com
Tue Jun 23 16:12:22 PDT 2015

You have looked in all the wrong places. Did you not read the JACK FAQ? You
don't need to know anything about ordering, or obscure ALSA configuration

Please re-read the JACK FAQ entry I pointed out at, try its advice. If that
doesn't work, tell us why.

But it also sounds as if you are attempting to use more than one audio
interface. If so, please read the other JACK FAQ entry on this also.

On Tue, Jun 23, 2015 at 5:56 PM, Cameron Metcalf <podeas at gmail.com> wrote:

> Despite some enlightening advice from a bunch of you, I'm still unable to
> resolve this so am sending out an inquiry one last time..
> I disabled the internal soundcard in the bios and stuck with the qjack
> interface to ensure that the external soundcard was being declared by
> "name" not number. I've tried various settings in qjack, diligently
> re-starting each time (sometimes rebooting) without success.
> I've also looked at the
> /etc/modprobe.d/alsa-base.conf file.
> I found that the external soundcard via USB was relegated to -2 (in order,
> I think, to prevent it from ever loading first). I changed this to 0, and
> then 1. THis didn't work.
> For my specific installation, I did not see a line "# ALSA module
> ordering". From the documentation I could not tell where/if I should really
> add this in.
> Lastly I was looking at:
> http://libremusicproduction.com/articles/demystifying-jack
> -%E2%80%93-beginners-guide-getting-started-jack and have followed those
> directions to the letter, but the microphone will not work.
> So I'm stuck with the same problem, I know if I were to re-install Ubuntu
> Studio, the microphone would work that very first time (even with the
> internal soundcard enabled), but it would not find  or allow it to record
> on subsequent sessions.
> Lastly, I've run: $ aplay -l
> command at the prompt. It sees my external card (just as jack does), but
> not the internal soundcard indicating to me, that the PreSonux 22VSL audio
> box is recognized by linux / jack, while the onboard sound card is proberly
> disabled.
> Any suggestions are appreciated. I'm giving myself a few more days before
> eliminating this distro and perhaps the hardware and linux altogether for
> music recording in this case.
> A sincere thanks to those of you who have already taken the time to
> respond last week.
> Cameron
> On Mon, Jun 15, 2015 at 8:30 AM, Paul Davis <paul at linuxaudiosystems.com>
> wrote:
>> http://jackaudio.org/faq/device_naming.html
>> On Sun, Jun 14, 2015 at 10:08 PM, Cameron Metcalf <podeas at gmail.com>
>> wrote:
>>> Hi everyone,
>>> I'm having trouble getting Ardour to receive audio signal from my mic.
>>> The microphone is going through a presonus AudioBox 22VSL.
>>> I've set up a fresh instance of Ubuntu Studio 14.04 on a 5 year-old Dell
>>> optiplex work station.
>>> Following the initial installation, I am able to start up Jack, then
>>> check the settings and ensure that the Presonus AudioBox is selected for
>>> both inputs and outputs.
>>> I open Ardour3 and start a new session: I add a stereo track. Right
>>> away, I can see that the meters are responding. I can record a short sound
>>> and play it back clearly.
>>> I close Ardour, I close Jack. I shut down the machine.
>>> I reboot and open Jack (start it) then open Ardour but it will NOT
>>> acknowledge the microphone and I cannot resume working on the file. I've
>>> tried installing ardour on different distros, different versions of ardour
>>> but I am unable to resolve this.  I've checked forums looking at how to
>>> connect the microphone on linux and know that I am successful as I outlined
>>> above. However I'm unable to retain a usable connection after the system
>>> has been shutdown.
>>> I thought maybe it had something to do with updates, so I started
>>> declining those, but the problem still persists.
>>> Please let me know if there is something obvious I can do to resolve
>>> this. I have done my fair share of research to see if I could resolve this
>>> problem on my own but have had no luck.
>>> Any suggestions on this topic would be appreaciated.
>>> Cameron
>>> _______________________________________________
>>> Ardour-Users mailing list
>>> ardour-users at lists.ardour.org
>>> To unsubscribe  or change your mailing preferences please visit:
>>> http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20150623/2287b126/attachment-0002.htm>

More information about the Ardour-Users mailing list