[Ardour-Users] Tranzport control surface under Ubuntu Studio 10.04

Giso Grimm gg3137 at vegri.net
Mon Mar 28 13:05:18 PDT 2011

On 01/14/2011 05:03 AM, Brett McCoy wrote:
> Has anyone gotten the Tranzport to work under Ubuntu Studio 10.04
> (kernel 2.6.32-25-generic)? I have tried every method listed on the
> Ardour site but every time I try to enable in Ardour, I get the
> message
>        [ERROR]: control protocol name "Tranzport" could not be initialized
> and a message to the console
>        Tranzport: cannot claim USB interface
> The device shows up under lsusb and the message
>       ardour: [INFO]: Control surface protocol discovered: "Tranzport"
> The device is created under /dev/bus/usb/<bus>/<dev>, like this:
> crw-rw-r-- 1 root root 189, 386 2011-01-13 22:57 /dev/bus/usb/004/003
> It always shows root:root permissions, even after setting up rules for
> udev. But even running ardour as root I can't get Tranzport to work.
> It worked fine when I'd previously had Fedora or Gentoo installed on
> this very same machine a couple years back. but not under this distro.

I am using the kernel space driver, see


for installation instructions. In recent kernels the tranzport device is
created as /dev/tranzport0, maybe the raw usb device is not usable if
the kernel driver is loaded (ardour 2.x uses the userspace driver by


More information about the Ardour-Users mailing list