[Ardour-Users] Unable to build ardour 2.8.9.

Juan Javier Martínez juanjavier.martinez at gmail.com
Sat Jun 19 04:02:07 PDT 2010

Debian Lenny. Packard Bell EasyNote TJ66 Pentium Dual core T4400 4gb RAM
Nvidia Geforce G210M.

Here is the log:

debian:/home/juanjavier/audio/ardour-2.8.9# scons vst=1
scons: Reading SConscript files ...
Checking for pkg-config version >= 0.8.0... yes
Checking for gthread-2.0... yes
Checking for lrdf... yes
Checking for libgnomecanvas-2.0... yes
Checking for gtk+-2.0... yes
Checking for jack... yes
Checking for sndfile... yes
Checking for samplerate... yes
Checking for glib-2.0... yes
Checking for libxml-2.0... yes
Checking for raptor... yes
Checking for fftw3f...yes
Checking for fftw3...yes
Checking for aubio...yes
Package vamp-sdk was not found in the pkg-config search path.
Perhaps you should add the directory containing `vamp-sdk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'vamp-sdk' found
OSError: 'pkg-config --cflags --libs vamp-sdk' exited 1:
  File "/home/juanjavier/audio/ardour-2.8.9/SConstruct", line 507:
    libraries['vamp'].ParseConfig('pkg-config --cflags --libs vamp-sdk')
  File "/usr/lib/scons/SCons/Environment.py", line 1371:
    return function(self, self.backtick(command))
  File "/usr/lib/scons/SCons/Environment.py", line 549:
    raise OSError("'%s' exited %d" % (command, status))

I tried export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

...and then...


...to no avail. Still the same. I followed the requirements listed in the
Ardour website in order to build the package.

As you noticed, I am trying to build the package *with* support for VST

Any help appreciated. Regards.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20100619/66b11c36/attachment-0002.htm>

More information about the Ardour-Users mailing list