[Ardour-Users] [Fwd: Re: Ardour and Jack question]

Al Thompson biggles58 at sbcglobal.net
Fri Feb 5 22:37:06 PST 2010

John Rigg wrote:
> On Thu, Feb 04, 2010 at 01:14:34PM -0500, Al Thompson wrote:
>> when I compiled it, it said it was not including
>> alsa support (although I tested jackd using alsa - using the same
>> startup configuration I was using with 0.109).
> Do you have the development version of your distro's alsa-lib
> package installed? On Debian it's called libasound2-dev (don't know
> about other distros).
> John

Yep, it's there.  Strangely, it seems to work using alsa as a backend. 
I dunno.  Every time I start to think I'm getting a handle on how linux
audio works, I get stumped again.

Here's where I've gotten to now.

Load jack normally on desktop using qjackctrl.  And it loads fine.

Load jack -R -d net on laptop.  It comes up and says 'creating driver'
or something close to that)

I run jack_netsource -H laptop on the desktop machine, and the two
appear to talk to each other.  The laptop changes its configuration, and
both show an occasional network xrun.  qjackctrl on the desktop shows 2
netjack audio ins and outs, and 1 netjack MIDI in and out.

However, if I run qjackctrl on the laptop, it doesn't show any netjack
'ports' at all, even though the two seem to continue to talk to each other.

How frustrating!


Check out the website I've been cobbling together.  It will never be done, but it's a start: 

My blog, with commentary on a variety of things, including audio, mixing, equipment, etc, is at:

Staat heißt das kälteste aller kalten Ungeheuer.  Kalt lügt es auch;
und diese Lüge kriecht aus seinem Munde: 'Ich, der Staat, bin das Volk.'
						- [Friedrich Nietzsche]

More information about the Ardour-Users mailing list