[ardour-users] Build problems midi++2 in ardour2.0rc2

Christian Schumann schumann at physik.uni-kl.de
Sat Apr 28 15:49:37 PDT 2007


I just upgraded my machine from debian sarge to debian etch, and also
tried to build ardour2.0rc2 on that machine for the first time. It's an
almost clean install with alsa 1.0.14rc3 built from source.

I came to the problem that there were undefined symbols in libmidi++,
which could only be solved by relinking libmidi++.so by hand also with
-lasound, which is not default in the build system.

So either my install is really weird, or it would be a nice idea to also
link to libasound in the default build system.


Dipl.-Phys. Christian Schumann   |Technische Universitaet Kaiserslautern
Mail: schumann at physik.uni-kl.de  |           Fachbereich Physik
Tel.: 0631/205-4842 (Office)     |     http://www.physik.uni-kl.de 
Tel.: 0631/205-4843 (Lab)        |
Fax.: 0631/205-3902              |    
Post: Erwin-Schroedinger-Strasse, D-67663 Kaiserslautern

More information about the Ardour-Users mailing list