[ardour-users] ardour 0.99.1 os x fonts disappeared (but working in 0.99)

Petter Sundlöf petter.sundlof at findus.dhs.org
Tue Feb 14 10:05:17 PST 2006

If you start Ardour from a terminal, try inputting

	export LC_ALL=""

in /Applications/Ardour.app/MacOS/ (or whatever it is called) and then 
starting the app there, with ./Ardour (or whatever the binary is 
called). You get there by "cd /Applications/Ardour.app/MacOS/" and list 
contents with "ls".

But really, Taybin and Jesse should have proper answers, I'm just a noob 
OS X user.

Libero Mureddu wrote:
> Maybe, but I have no idea how to check this, and how to change those
> settings. Can you give me some hints?
> Libero
> On 2/14/06, Petter Sundlöf <petter.sundlof at findus.dhs.org> wrote:
>>Just a chance guess, but do you have any special localization settings?
>>Like LC_ALL or similar? Setting this in some variations resulted in no
>>fonts on Tiger for me.
>>Libero Mureddu wrote:
>>>I tried to open an older version of ardour, I think it was the 0.99,
>>>don't remember if it was the tiger-optimized or not, BTW this one
>>>opens with all the fonts (like ardour2). So my problem seems to be
>>>related with the 0.99.1 versions, even if they worked until two days
>>>Here is the console log about the "old" 0.99 version.
>>>mac os 10.4.4 ibook g4,
>>>best regards,
>>>Libero Mureddu
>>>===== martedì 14 febbraio 2006 16:26:38 Europe/Helsinki =====
>>>jackd 0.100.6
>>>Copyright 2001-2005 Paul Davis and others.
>>>jackd comes with ABSOLUTELY NO WARRANTY
>>>This is free software, and you are welcome to redistribute it
>>>under certain conditions; see the file COPYING for details
>>>JACK compiled with POSIX SHM support.
>>>loading driver ..
>>>GLib-WARNING **: getpwuid_r(): failed due to: Result too large.
>>>Ardour/GTK 0.99
>>>   (built using 1.0.0 with libardour 0.901.2 and GCC version 4.0.0
>>>(Apple Computer, Inc. build 5026))
>>>Copyright (C) 1999-2005 Paul Davis
>>>Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker
>>>Ardour comes with ABSOLUTELY NO WARRANTY
>>>This is free software, and you are welcome to redistribute it
>>>under certain conditions; see the source for copying conditions.
>>>XFree86 Version 4.4.0 / X Window System
>>>(protocol Version 11, revision 0, vendor release 6600)
>>>_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
>>>[DRI] screen 0 installation complete
>>>Screen 0 added: 1024x768 @ (0,0)
>>>Could not init font path element /usr/X11R6/lib/X11/fonts/CID/,
>>>removing from list!
>>>Loading UI configuration file
>>>Loading user configuration file /Volumes/scripta/Users/libero//.ardour/ardour.rc
>>>ardour: [WARNING]: no MIDI ports specified: no MMC or MTC control possible
>>>ardour: [INFO]: Apple VecLib H/W specific optimizations in use
>>>cannot create new client; ardour already exists
>>>cannot complete client connection process
>>>cannot read response from jack server (No such file or directory)
>>>JARInsert Critical Log: error = 1.
>>>ardour: [ERROR]: KeyboardTarget: unknown action "toggle-recorder-window"
>>>ardour-users mailing list
>>>ardour-users at lists.ardour.org
> _______________________________________________
> ardour-users mailing list
> ardour-users at lists.ardour.org
> http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org
> This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail.

More information about the Ardour-Users mailing list