[ardour-users] JACKD problem on Debian KDE system

woweepratt at comcast.net woweepratt at comcast.net
Thu Sep 1 21:49:38 PDT 2005

Okay the fun has begun! I still have a problem though, probably easy to fix.

I've got JACKD, Ardour and even Rosegarden4 working with no problems...

as long as I'm logged in as root.

If I log in as my ordinary user qjackctl gives me s**t and says it can't connect. 

Is this a simple problem to fix?

FYI. I'm using Simply Mepis with a debian 2.6.10 kernal again. I fouund that my installation problems with Jackd adn Ardour disappered if I removed the unstable repositories from my synaptic list.

Yup, I'm a noob! 


> Hi,
> What version of debian are you using, and where are you taking the
> packages for ardour, jackd and kde from? The unstable distribution (sid)
> is seeing a lot of transitions currently [1], so that some packages
> cannot be installed together (or at all) for the moment. Also, if you
> are using stable (sarge) or testing (etch), and try to install packages
> that were made for unstable, you can get into troubles. If you are using
> stable or testing packages only, you should not have any problem...
> Concerning jack, there is an ongoing transition from libjack0.80.0-0
> (used in the stable distribution and, for now, in testing too) to the
> new libjack0.100.0-0 packages. Packages in unstable that depend on jack,
> and have not yet been rebuilt against libjack0.100.0-0, cannot be
> installed. For example, rosegarden4 in unstable cannot be installed [2].
> So what are the versions of the packages you want to install?
> Yours,
> Jérémie
> [1] http://lists.debian.org/debian-devel-announce/2005/08/msg00014.html
> [2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=317217
> Le jeudi 01 septembre 2005 à 09:55 -0500, WoWeePratt a écrit :
> > I have tried for several days to understand and fix a problem with JACKD and 
> > Ardour and am asking for some help and guidance.
> > 
> > The first problem is that when I try installing Ardour using Synaptic the 
> > installation fails because of a JACD dependancy. yet, JACKD is installed on 
> > my system, it's just an old version.
> > 
> > Second problem is updating JACKD. I go to update JACKD and it wants to rip 
> > out KDE in the process.
> > 
> > Thrid problem, JACKD updates and installs, takes out KDE, and I login in at 
> > the prompt. I run apt-get install kde and basically it says no problem, will 
> > do, but it wants to REMOVE JACKD!
> > 
> > What gives? 
> > 
> > _______________________________________________
> > ardour-users-ardour.org mailing list
> > ardour-users at lists.ardour.org
> > http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org
> _______________________________________________
> ardour-users-ardour.org mailing list
> ardour-users at lists.ardour.org
> http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org

More information about the Ardour-Users mailing list