[ardour-users] qjackctl & OS X

Mark Knecht markknecht at gmail.com
Sun Oct 30 19:41:28 PST 2005

On 10/30/05, Jesse Chappell <jesse at essej.net> wrote:
> On 10/30/05, Mark Knecht <markknecht at gmail.com> wrote:
> > Jesse,
> >    I've downloaded and tried running QJC on my Mac Mini. I think I'm
> > not possibly understanding your instructions above. The GUI is fine
> > but what 'button the right of the interface combo' are you speaking
> > about and where do I find the 'human readable device name'? So far I
> > cannot get Jack to start. I figure it's because I'm not passing the
> > name of something correctly.
> In the Setup dialog, look for the Interface combobox.  To the right of
> that there is a button with a > in it.  Press that and you'll get the
> popup menu where you can pick the audio device (in your case the Built
> In audio).
> Also make sure to set the Server Path to /usr/local/bin/jackd .
> If you still have problems, show up on IRC, I get too impatient with
> the latency of email...

OK, I saw that one. All it says in my case is '(default)'. That
doesn't seem too helpful to me...

I saw the note from Eduard about changing the server path so I tried
that and got more intersting results:

19:36:57.644 /usr/local/bin/jackd -v -R -dalsa -dhw:0 -r48000 -p1024 -n2 -i0 -o0
19:36:57.657 JACK was started with PID=307 (0x133).
getting driver descriptor from /usr/local/lib/jack/jack_coreaudio.so
getting driver descriptor from /usr/local/lib/jack/jack_portaudio.so
jackd: unknown driver 'alsa'
19:36:57.892 JACK was stopped with exit status=1.
19:36:59.817 Could not connect to JACK server as client.

To me this seems more correct. Now it's down to the point where I
would need to stange named device he has, but I cannot find that
device name so far. I tried changing to coreaudio. Now Jack starts but
I get lots of strange messages:

19:39:49.998 Patchbay deactivated.
19:39:50.084 Statistics reset.
19:39:53.019 JACK is starting...
19:39:53.022 /usr/local/bin/jackd -R -dcoreaudio -r48000 -p1024 -i0 -o0
19:39:53.033 JACK was started with PID=311 (0x137).
jackd 0.100.1
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with POSIX SHM support.
loading driver ..
JAR: Reading Preferences fInputChannels: 2 fOutputChannels: 2 fAutoConnect: 1
JAR: Reading Preferences fDefaultInput: 2 fDefaultOutput: 2
fDefaultSystem: 1 fDeviceID: 0
JAR: Blacklisted client Xquartz
JAR: Initialize [inSelf, name] : 3168480 jackd
JAR: Rejected client : jackd
JCA: error: calling AudioUnitSetProperty -
kAudioOutputUnitProperty_ChannelMap-INFO 1
JCA: error: calling AudioUnitSetProperty -
kAudioUnitProperty_StreamFormat kAudioUnitScope_Input
JCA: error: calling AudioUnitSetProperty -
kAudioUnitProperty_StreamFormat kAudioUnitScope_Output
19:39:55.413 Server configuration saved to "/Users/mark/.jackdrc".
19:39:55.414 Statistics reset.
19:39:55.418 Client activated.
19:39:55.456 Audio connection graph change.
19:40:04.948 Client deactivated.
19:40:05.418 JACK is stopping...
jack main caught signal 15
no message buffer overruns
JAR: Teardown [inSelf, name] : 3168480 jackd
JAR: --------------------------------------------------------
JAR: KillJackClient
JAR: Teardown : AudioHardwareStreamsDied
JAR: error code : kAudioHardwareNoError
JAR: Teardown : no connection to HAL
19:40:05.683 JACK was stopped successfully.

but at least it runs! ;-)

- Mark

More information about the Ardour-Users mailing list