[ardour-users] Problem building ardour-1.0beta29

James Fleming ardour at electronic-quill.net
Mon May 23 04:49:16 PDT 2005

I'm guessing this is an issue with the OS environment (somewhat modified
Fedora 2), but haven't yet managed to figure out just what. I've also
made sure I have the latest versions of the immediately dependent files,
but that still doesn't mean I haven't borked something else.

Many versions of Ardour up to and including 1.0beta28 have compiled
happily enough, so this issue is new with beta29.

The output of scons, after running the initial checks, is:
scons: done reading SConscript files.
scons: Building targets ...
scons: `ardour.rc' is up to date.
scons: `libs/soundtouch/libsoundtouch.a' is up to date.
scons: `libs/sigc++/sigc++config.h' is up to date.
scons: `libs/sigc++/libsigc++.a' is up to date.
scons: `libs/pbd/libpbd.a' is up to date.
scons: `libs/midi++/libmidi++.a' is up to date.
scons: `libs/ardour/libardour.a' is up to date.
cd libs/gtkmm && sh ./autogen.sh
/usr/share/aclocal/pkg.m4:5: warning: underquoted definition of
  run info '(automake)Extending aclocal'
    or see
	aclocal: configure.ac: 166: macro `AM_PATH_GTK' not found in library
	scons: *** [libs/gtkmm/config.h.in] Error 1
	scons: building terminated because of errors.

Running `sh autogen.sh` from within libs/gtkmm gets the same result. It
also does the same from within libs/sigc++, both in beta29 and the
latest CVS snapshot.
There's a comment in configure.ac by mirko about AM_PATH_GTK, but that
dates from '98.

If anybody can point me towards figuring out what I've broken, I'd be
very grateful.

Thanks in advance,
Stupidity killed the cat.
Curiosity was framed.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20050523/2a88f7d9/attachment.pgp>

More information about the Ardour-Users mailing list