[ardour-users] One session, Two crashes ( a drama )

Ben Powers bennyp at rogers.com
Sun Mar 20 08:49:52 PST 2005

Once upon a time, in a land beset by proprietary bear traps and 
freedom-seeking wood-elves....

Ardour Crash Report
OS: Mac On X v 10.3.8
Ardour Version : 0.9 beta 28
windowmanager: quartz-wm
Interface: Built-In Audio (iBook)

Incedent one:

Error messages:

Gtk-CRITICAL **: file gtkwidget.c: line 3310 
(gtk_widget_set_sensitive): assertion `widget != NULL' failed.

Gtk-CRITICAL **: file gtkwidget.c: line 3310 
(gtk_widget_set_sensitive): assertion `widget != NULL' failed.
Segmentation fault

	I was editing a previously saved 3 track session. I switched to timefx 
cursor mode and highlighted a rogion to be stretched. I selected region 
bounds from the snap to menu, then stretched the end of the one region 
to meet the start of the next. When the operation was done, the small 
dialog/progress box for the timefx tool remained open with the progress 
bar at full. The region's waveform was visibly changed, but the region 
bounds were of the same Size. I switched to object mode to attempt 
manual resizing. (which I had tried before in a a similar incident 
before with no success) In order to use the editor window, I had to 
first close the progress dialog box for timefx, it was at this point, 
right after I closed the window that ardour segfaulted.

Incident Two:

Error Message:
Bus error

	Several minutes later, while working on the same session, I was 
importing some audio files. The first one I copied and resampled from 
48000 to 44100, the second, I imported (linked). I was beginning to 
copy and paste the regions back to back, and I decided to just 
re-import the linked region a number of times, because the sound 
library window was open. I imported it once, then switched to edit 
window and tried to move the edit cursor with "e". that did not respond 
so I just dragged it over, then I switched back to the sound library 
window and pressed import once more. The button remained in the pressed 
position, and the window did not respond, though I could still move it. 
When I closed the window, I got a watch hand cursor on the edit window 
surface, and when I clicked on the edit window, It crashed.

End religious persecution in China!
Join Friends of Falun Gong

More information about the Ardour-Users mailing list