[ardour-users] alsa can't find my es1371 card

Keith kmceng at yahoo.com
Sun Jun 13 10:43:03 PDT 2004

---Thac wrote---
> did you read the last part about doing an lsmod and the rmmod any 
> conflicting capabilty modules first?

I just looked and couldn't find any reference to lsmod or rmmod.  I never
found any instructions on how to do this other than the few command lines
like the one I tried.

I just did rmmod on all es1371 entries: soundcore, ac97_codec, gameport, 
then rmmod snd-page-alloc

Then I went into Mandrake Control Center and disabled sound there.
(ALSA was already NOT running)

Then I tried 
#modprobe -v realcap any=1
insmod /lib/modules/2.6.7-0.rc3.1.sds.1mdk/kernel/security/realcap.ko.gz any=1
FATAL: Error inserting realcap
(/lib/modules/2.6.7-0.rc3.1.sds.1mdk/kernel/security/realcap.ko.gz): Invalid argument

Seeing the very LAST thing, it would seem the problem is more fundamental.
It would seem it doesen't even like how the command was entered (invalid argument)

The closest I came to any success was using the following:
# insmod /lib/modules/2.6.7-0.rc3.1.sds.1mdk/kernel/security/realcap.ko.gz any=1
insmod: error inserting '/lib/modules/2.6.7-0.rc3.1.sds.1mdk/kernel/security/realcap.ko.gz': -1
Invalid module format

So I tried both the gzipped and ungzipped versions, but neither succeeded.

It also, it disturbs me that alsaconf can't even find my sound card. But pciscan -vO returns:
pci bus 0x0000 cardnum 0x09 function 0x00: vendor 0x1274 device 0x1371
 Ensoniq ES1371 [AudioPCI-97]
  STATUS    0x0410  COMMAND 0x0105
  CLASS     0x04 0x01 0x00  REVISION 0x08
  BIST      0x00  HEADER 0x00  LATENCY 0x20  CACHE 0x00
  BASE0     0x0000dc01  addr 0x0000dc00  I/O
  MAX_LAT   0x80  MIN_GNT 0x0c  INT_PIN 0x01  INT_LINE 0x09


Do you Yahoo!?
Friends.  Fun.  Try the all-new Yahoo! Messenger.

More information about the Ardour-Users mailing list