[Ardour-Dev] Ardour-Dev Digest, Vol 153, Issue 14 / tried to announce a bug already

Dr. Michael Kuhlmann RuA.Kuhlmann at t-online.de
Tue Jan 17 03:18:01 PST 2017

Hi Toby,

thank you for your answer on Mantis: http://tracker.ardour.org/view.php?id=7157 - and excuse me please for not having answered yet (I just learned a minute ago that you had written in there). 

Your new message in here means that the solution decribed in Mantis (which I will have to check out - since it's my first encounter with Ardour's configuration files) does not work completely...?

Your message in Mantis means that there is a configuration text file a/libs/ardour/region.cc ? I can't find it on my system, unfortunately...

Thanks again

Dr. Michael Kuhlmann
Wedelstraße 84
47807 Krefeld

Betreff: Ardour-Dev Digest, Vol 153, Issue 14
Datum: 2017-01-16T22:01:05+0100
Von: "ardour-dev-request at lists.ardour.org" <ardour-dev-request at lists.ardour.org>
An: "ardour-dev at lists.ardour.org" <ardour-dev at lists.ardour.org>


Message: 1
Date: Mon, 16 Jan 2017 16:50:40 +0000
From: Tobi Stadelmaier <stadeltobi at gmail.com>
To: ardour-dev at lists.ardour.org
Subject: [Ardour-Dev] Issue 0007157: Cannot move an automation curve
	together with a region
	<CAGGwtJ9VSZh9EBx8BfEF4=u6rM2YMWRafSLa2M1MhDizEycmHQ at mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Hi everyone,

I'd like to make you aware of the issue above, since it bit me personally,
but more importantly, I think it's something that might well break someone
else's workflow.

Effectively, the checkbox that says "move automation together with regions"
in the preferences is ineffective in recent Ardour versions - it broke just
after 5.0, and has been broken ever since. With a current version, you
can't have Ardour move the automation of one track together with your edits
of the regions any more. No matter if you have that checkbox set or not,
the automation data of a track stays where it is, even when you move a
region (or ripple-delete it, for that matter). Which I think certainly has
the potential to be a major pain for certain users.

The workaround that did it for me is to consolidate the track _before_ you
move things around, but that's really only a workaround for sure.

Anyway, I bisected it to a certain commit, and double-checked whether this
really fixed it for me - details are in the bug report.

Now, while I'm now personally running a patched version of 5.5 that solves
it for me, I am really a bit uncomfortable with the alleged "fix" - the
commit in question clearly tried to fix _another_ thing, which is not a
factor in my personal workflow (since I don't use midi), so I'd be much
more comfortable if someone who knows their way around the region.cc file
could take a look. Quite honestly, I have no idea what the commit in
question tried to do in the first place. But I'd be glad to learn :)

Of course I'll be happy to help (bear in mind that I'm a Java person,
though, and was basically banging my head against the keyboard until it
worked for me again :)) But I'd certainly be able to help with testing a
real fix, do some more bisection, or whatever. Just let me know.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-dev-ardour.org/attachments/20170116/50e3d3a7/attachment.html>


Subject: Digest Footer

Ardour-Dev mailing list
ardour-dev at lists.ardour.org


End of Ardour-Dev Digest, Vol 153, Issue 14

More information about the Ardour-Dev mailing list