[Ardour-Dev] Do I need to upgrade any libs (or gcc) to build 2.7 ?

torbenh at gmx.de torbenh at gmx.de
Fri Feb 20 14:19:39 PST 2009

On Wed, Feb 18, 2009 at 10:32:56AM +0100, Paul Davis wrote:
> On Wed, Feb 18, 2009 at 9:49 AM, John Emmas <johne53 at tiscali.co.uk> wrote:
> > Until this morning I was running Ardour 2.5 on my laptop.  A couple of days
> > ago, one of the developers asked me to check if a bug was still present in
> > the latest version so this morning I did a svn update and I'm now trying to
> > build svn 4619 (presumably version 2.7.something ?)
> >
> > I'm not sure how far it's getting (possibly to the vamp-sdk branch) but
> > I see a lot of errors looking something like this:-
> John, there have been no changes to ardour's library requirements. The error
> you are getting, sounds like a system-specific configuration error on your
> machine. It is possible that nobody building ardour after we included VAMP
> and RubberBand ever tried with gcc 4.1.2, and if thats the case, then its
> simply a bug in that version of the stdc++ library that comes with 4.1.2.
> however, i doubt that since libstdc++ doesn't really that much ...

i am still using gcc-4.1.2 as this is still gentoo stable compiler,
so expect me to catch something related to it. 

although i dont build a2 very often.
well... problem solved anyways.

> _______________________________________________
> ardour-dev mailing list
> ardour-dev at lists.ardour.org
> http://lists.ardour.org/listinfo.cgi/ardour-dev-ardour.org

torben Hohn
http://galan.sourceforge.net -- The graphical Audio language

More information about the Ardour-Dev mailing list