[Ardour-Dev] Do I need to upgrade any libs (or gcc) to build 2.7 ?

Paul Davis paul at linuxaudiosystems.com
Wed Feb 18 01:32:56 PST 2009

On Wed, Feb 18, 2009 at 9:49 AM, John Emmas <johne53 at tiscali.co.uk> wrote:

> Until this morning I was running Ardour 2.5 on my laptop.  A couple of days
> ago, one of the developers asked me to check if a bug was still present in
> the latest version so this morning I did a svn update and I'm now trying to
> build svn 4619 (presumably version 2.7.something ?)
> I'm not sure how far it's getting (possibly to the vamp-sdk branch) but
> I see a lot of errors looking something like this:-

John, there have been no changes to ardour's library requirements. The error
you are getting, sounds like a system-specific configuration error on your
machine. It is possible that nobody building ardour after we included VAMP
and RubberBand ever tried with gcc 4.1.2, and if thats the case, then its
simply a bug in that version of the stdc++ library that comes with 4.1.2.
however, i doubt that since libstdc++ doesn't really that much ...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-dev-ardour.org/attachments/20090218/ecadcb13/attachment-0002.htm>

More information about the Ardour-Dev mailing list